Can't find the add-in

Hi Daniel,

Just discovered your tool, very excited about being able to export high quality graphics from Excel for academic work. Unfortunately, after having installed the Toolbox (under Program Files, as suggested by one user here) the add-in doesn’t show up in the COM add-in list. I’ve tried to add it manually but this doesn’t appear to work either. I’m running Windows 10 and Excel 2016. I’m not sure how to move forward from this.

Thanks in advance for taking the time.
All the best,

Chris

Hi Chris,

is this a managed IT environment? Do you know if your user profile sits on a server somewhere in the network? I’ve had all kinds of weird add-in problems with such setups. If this is the case, you may have to manually tweak the Windows registry.

However, I don’t see why it should not work when installed in the user profile folder. Evidently it did not work for someone in your organization, but I’d give it a try nonetheless, then let’s work from there. But remove the add-in (via “Add/Remove Software”) first.

Please let me know if it works or not.

Daniel

OK I have exactly the same problem. I am using a standalone machine, not on a network and have windows 10 and excel 2016.

I’ve tried installing & uninstalling, moving files around… nothing seems to happen automatically so I need to do something, but what?

Looking at File > Options > Addins, there is nothing about XL Toolbox in the list.

The Excel Add-ins option is looking for a .XLAM, .XLA or .XLL file and I can’t find any of those in the installed folders under XLToolbox.

The COM Add-ins option is looking for .EXE or .DLL files and I have the opposite problem: too many of these, which one do I choose? or none?

image

Thanks for any help or advice, like so many others I am really grateful this app exists and hoping to be able to export my charts!

I have the same problem with you. I tried every .DLL file and none is valid in COM Add-ins option. :disappointed: :disappointed:

I apologize for the delay in responding. This is a “VSTO”-Addin (Visual Studio for Office), which is why you can’t simply choose a .DLL or .XLAM file. There is a file XLToolboxForExcel.vsto which, when double-clicked, should install the add-in into Excel.

I just now installed the Toolbox on a fairly new Windows 10 machine which I had recently set up, but had forgotten to install the Toolbox:

image

One big problem is that the add-in is not cryptographically signed. Code-signing certificates are expensive, and you don’t buy them once, you have to rent them. That’s why I don’t have a proper certificate for the Toolbox. This issue keeps popping up though. You might also try to install the Toolbox with any antivirus software temporarily turned off (although I would expect that you had been presented with some sort of warning if antivirus really was a problem).

Finally, you could send me the installation log file which resides in the %TEMP% folder (press WIN+R and enter %TEMP%). Sort by descending modified date and locate a file called Setup Log 2020-02-xx #001.txt (where xx is the current date of course). You can send me this as a private message in this forum or by email to daniel at xltoolbox dot net.

I’m sorry I can’t be of much more help right now.

Hi Danel,
I have a similar problem. I can not find the add-in in the list, and I could not add manually by choosing the .vsto file. I tried to doubleclick the file, but then I should choose the application to open it, which, I presume, is not the proper method. I have windows 10 nad excle 365.
Thank you for your help!