Excel 2010 and solver error 53

Hi Daniel,

You’ve previously tried to address this issue from another user within this post:
sourceforge.net/p/xltoolbox/disc … /0fe4f8a6/

I’ve encountered the same issue but with Excel 2010 in Windows 7. I understand according to your post that you do not have Windows 7 to test this, but I believe I’ve came across an interesting solution:
social.technet.microsoft.com/For … excel-2010

Is the SetDllDirectory call used in your addin?

Thanks for your hard work with this.


thanks for the link! For the first time I was able to reproduce the error on my main system (using Windows XP and Office 2010, both 32-bit). Yes I do use SetDllDirectory(). I’m going to have to research alternative ways to load the DLLs. One thing I do not want to do is install the DLLs into a system folder, as this would mean the Toolbox installation would require administrator rights.

Kind regards


Glad to hear you were able to reproduce it. From what I’ve gathered googling around, incompatibilities between the solver and add-ins are common due to this odd error. Good luck!

Once I knew what the problem was, it was easy to fix it. I uploaded a new beta version (6.20 beta 3) which at least on my system no longer causes problems with the solver addin. Would you like to test it? It is available at http://sourceforge.net/projects/xltoolbox/files/beta/XL_Toolbox_6.20beta3.exe/download. Please let me know if it works for you.


Hi Daniel,

Your changes seem to have worked. No errors :slight_smile: Well done!

I’m glad I could help with this one.

Good luck with your work.


There are 4 series of lines and each lines consists 12 data points.
And I want to annotate each data point in the line.
So it should appear 1-12 for 12 data points for all the 4 series.
What happened now was only 1 series was in this order and another series is appearing ‘12’ for all data points.